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TEMPCOMPRTC-RD

TEMPERATURE COMPENSATED REAL TIME CLOCK 
REFERENCE DESIGN KIT USER'S GUIDE

1. Kit Contents
Temperature Compensated RTC Evaluation Board
AC to DC Power Adapter
Straight DB9 serial cable (male-female)
Straight DB25 parallel cable (male-male)
Quick-start Guide
Reference Design Kit CD-ROM containing the following items:
 Temperature Compensated Real Time Clock Reference Design Programmer’s Guide (AN293) and 

associated software (AN293SW.zip).
 Keil Software 8051 Development Tools (evaluation assembler, 2 kB limited compiler, and linker).

2. Requirements
The Temperature Compensated Real Time Clock Reference Design Kit is a completely independent evaluation
platform with preloaded firmware. The following are the only requirements to evaluate this reference design without
any modifications to the firmware.
PC with the following features:

Operating system: Windows 2000/XP/Server2003
One available serial port

One available parallel port (required to evaluate the optional SMBus/I2C interface)

Although the instructions in this user’s guide are written for a PC running the Windows OS, PCs with other
operating systems can also be used to evaluate this design as long as a serial port and a terminal program are
available.
In order to modify, rebuild, and download code into the C8051F300 MCU on this evaluation board, the following
additional items are required but not included in this kit:

USB Debug Adapter and USB cable, or Serial Adapter and RS-232 serial cable
Full version of Keil Software C51 assembler, compiler, and linker

The C8051F300DK Development Kit includes the USB Debug Adapter and USB cable along with a C8051F300-
TB Target Board.
Note: A full version of the Keil tool chain is required in order to modify and recompile the code provided with this reference

design because the code size is greater than the evaluation tool chain’s code size limits. Alternatively, the source code
can be ported to work with other 8051 tool chains that are supported by the Silicon Labs IDE. For a list of currently sup-
ported tool chains, please refer to the following MCU Knowledge Base Article: http://portal.knowledgebase.net/arti-
cle.asp?article=173563&p=4120

http://portal.knowledgebase.net/article.asp?article=173563&p=4120
http://portal.knowledgebase.net/article.asp?article=173563&p=4120
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3. Kit Overview
The Temperature Compensated Real Time Clock (TC-RTC) Reference Design Kit includes an evaluation board
that utilizes a Silicon Laboratories C8051F300 Mixed Signal Microcontroller. This kit offers the following features:

Low-cost Temperature Compensated Real Time Clock and Calendar
56-byte General Purpose Non-Volatile RAM
RS-232 Serial Interface

Optional SMBus/I2C Interface
Full source code for the TC-RTC firmware is included

The board is pictured in Figure 1, with the major components labeled. The MCU on the board is preloaded with the
TC-RTC firmware with UART interface, and the included CD-ROM contains the firmware source code. More
information about this reference design can be found in “AN293: Temperature Compensated Real Time Clock
Reference Design Programmer’s Guide.” The following sections demonstrate the features of this reference design.

Figure 1. Temperature Compensated RTC Evaluation Board
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4. TC-RTC Evaluation Board
The functions of the major components on the TC-RTC Evaluation Board that are labeled in Figure 1 are listed
below. The board schematic and bill of materials are shown in Sections 7 and 8, respectively.

C8051F300 MCU (U3)—Microcontroller with firmware to perform the TC-RTC function.
32.768 kHz Crystal (Y1)—This low-cost watch crystal is used for time keeping.
DB9 connector (J5)—This is for the serial RS-232 connection.
DB25 connector (J6)—This is for the optional parallel connection with SMBus interface.

In addition to these, a RS-232 transceiver and a buffer are used for the serial and SMBus interfaces, respectively.

5. TC-RTC Firmware
The clock accuracy of a time-keeping system based on a resonating quartz crystal is primarily affected by the
variation of crystal frequency with respect to temperature. Figure 2 shows a plot of the variation of crystal
frequency versus temperature. From the parabolic curve, it can be seen that the RTC will lose time if the
temperature is increased or decreased from the room temperature value (25 °C). The RTC will never have a
positive error caused by temperature variations (i.e., gain time) because the maximum frequency is at room
temperature. 

Figure 2. Crystal Frequency Variation Due to Temperature

The TC-RTC firmware running on the C8051F300 MCU eliminates this time loss because of temperature
variations. It uses the on-chip ADC and temperature sensor to measure the temperature every minute and
compensate for the lost time at the end of the day by adding the accumulated error to the RTC’s reported time.
This is explained in more detail in “AN293: Temperature Compensated Real Time Clock Reference Design
Programmer’s Guide”. 
The time maintained by the TC-RTC can be accessed via two interfaces—a RS-232 serial interface via a DB9
connector and an SMBus interface via a DB25 connector. The preloaded firmware is built to work with the RS-232
serial interface. Also included in the AN293SW.zip package is a pre-built OMF file, which enables the SMBus
interface to the RTC when loaded into the device. The AN293SW.zip package contains the full source code as
well.
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6. TC-RTC Demonstration
The following step-by-step demonstration explains the various features and capabilities of this reference design.
There are two interfaces available for the RTC—UART and SMBus, which are demonstrated in sections 6.1 and
6.2, respectively.

6.1. UART Interface Demonstration
The TC-RTC Evaluation Board comes preloaded with firmware that enables the UART interface. The following
sections show how to set up and use this interface.

6.1.1. PC Software Setup
On the PC, set up HyperTerminal to use the COM port at 9600 baud, 8-N-1, and no flow control. Detailed
instructions to set this up are shown below.
1. Launch HyperTerminal from your Start Menu: Start Menu→Programs→Accessories→Communications→ 

HyperTerminal.
2. Type any name for the new connection, and click OK.
3. In the”Connect using:” drop-down list, Choose “COM1”, or if you have multiple COM ports, choose the one you 

want to use.
4. Set up the COM1 Properties dialog as shown in Figure 3, and click OK.
5. Select “File→Properties→Settings→ASCII Setup”. Check the box marked “Echo typed characters locally”, and 

click OK. See Figure 4.

Figure 3. HyperTerminal Settings
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Figure 4. HyperTerminal ASCII Setup

6.1.2. Hardware Setup
1. Connect the provided DB9 serial cable between the PC’s serial port and the TC-RTC evaluation board 

connector J5.
2. Apply power to the evaluation board using the provided dc power adapter.

6.1.3. Interacting with the TC-RTC
1. After the board is powered on for the first time, the board firmware will perform a temperature sensor/ADC offset 

calibration. For valid calibration, a soak period is required before the calibration is done. Wait for 15 seconds for 
calibration to complete. At the end of calibration, the green LED on the board will start blinking at a 1 Hz rate.

2. HyperTerminal should now be displaying initial date, time and temperature information from the board. You can 
program the current date and time data into the board. This data should be trans-coded to the format expected 
by the device firmware. Refer to "Appendix B—TC-RTC: Implementation Details" on page 12 for the data 
format. Note that the AM/PM information is encoded in the same byte as the hour. Here are some examples:

06:31:09 PM, Thursday, May 04, 2006→09 31 66 04 04 05 06
11:05:39 AM, Saturday, December, 08, 1979→39 05 51 06 08 12 79

3. Type the “s” command to toggle off the auto-display mode that displays the time once every second. Note that 
commands should be only in lower case.

4. Type the following “w” command (write) to program the device with a new time and date. See "Appendix A—TC-
RTC: Supported Commands" on page 11 for command formats.

w000709316604040506
5. Type the “r” command (read) to get the current time and date information from the device.

r0007
6. Type the “s” command to toggle on the auto-display mode.
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Figure 5. Interacting with the TC-RTC—HyperTerminal Session

An index of all supported commands is available in "Appendix A—TC-RTC: Supported Commands" on page 11.
Detailed information about this reference design is contained in “AN293: Temperature Compensated Real Time
Clock Reference Design Programmer’s Guide”.

6.2. SMBus Interface Demonstration

The TC-RTC Evaluation Board can be loaded with firmware that can enable an SMBus/I2C interface. This is
described in the following sections.

6.2.1. Firmware Download
The TC-RTC Evaluation Board comes preloaded with firmware that enables the UART interface. In order to enable
the SMBus interface, alternate firmware has to be loaded on the device. The steps in this section will guide you
through downloading the TC-RTC firmware with SMBus interface to the TC-RTC evaluation board.
1. Install the Silicon Laboratories IDE from the Reference Design Kit CD. Launch the IDE by choosing "Start 

Menu→All Programs→Silicon Laboratories→Silicon Laboratories IDE". If you need more information about 
installing and using the IDE, please refer to the C8051F300DK Development Kit User's Guide, which is 
available on this web page:
http://www.silabs.com/tgwWebApp/public/web_content/products/Microcontrollers/en/C8051F300DK.htm

2. Depending on which type of debug adapter you have, set up the hardware as shown in one of the two diagrams 
below (Figure 4, Figure 5). Consult the C8051F300DK User’s Guide if you need detailed instructions.

http://www.silabs.com/tgwWebApp/public/web_content/products/Microcontrollers/en/C8051F300DK.htm


TEMPCOMPRTC-RD

Rev. 0.1 7

Figure 6. Hardware Setup using a Serial Adapter

Figure 7. Hardware Setup using a USB Debug Adapter

3. Before connecting to the target device, several connection options may need to be set. Open the “Connection 
Options” window by selecting “Options→Connection Options...” in the IDE menu. First, select the adapter that 
you are using in the “Serial Adapter” section. Next, the correct “Debug Interface” must be selected. C8051F30x 
family devices use the Silicon Labs 2-wire (C2) debug interface. Once these selections are made, click the OK 
button to close the window. 

4. Click the “Connect” button in the toolbar or select “Debug→Connect” from the menu to connect to the device. 
You will see the text “Target: C8051F300” in the status bar of the IDE if the connection was successful. 

5. Choose the “Project→Download Object File…” option. This shows a “Download” dialog. Click the ”Browse” 
button and select the TC-RTC firmware pre-linked OMF file from this path:
C:\Silabs\MCU\TemperatureCompensated_RTC_RD\Firmware\TEMPCOMPRTC_RD_SMBUS.OMF

6. Click the “Download” button to download this firmware to the ‘F300 device. You will see the text “Download 
successful” in the Build window if the firmware was downloaded successfully.

7. Disconnect the dc power adapter and the ribbon cable from the target board.

6.2.2. Hardware Setup
1. Connect the DB25 parallel cable provided with the kit between the PC’s parallel port (printer port) and the 25-pin 

connector on the TC-RTC Evaluation board (J6).
2. Apply power to the board by connecting the dc power adapter.
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6.2.3. Interacting with the Windows SMBus Test Software

The TC-RTC Evaluation Board with the SMBus firmware enables an SMBus/I2C interface to the RTC. In order to
test this interface, PC software is provided that emulates an SMBus master via the PC’s parallel port. 
1. The PC Software is installed as part of the TC-RTC RD installation from the Reference Design Kit CD. Launch 

this by selecting the following: Start Menu→All Programs→Silicon Laboratories→TC-RTC SMBus Test.
2. Make sure that the green LED is blinking on the board, and then click the “Refresh All” button. This updates all 

the values shown.
3. Modify any value(s) that you would like to modify, and click the corresponding “Write”, “Write NVRAM”, or “Write 

Selected” button. This will write the value(s) to the board.
4. Clicking the “Read” button will read the current values from the board.
5. Check the “Auto-refresh Time/Date” check box to automatically update values every second. Note that when 

this is checked, the other read/write buttons are disabled.

Figure 8. TC-RTC SMBus Interface Test Software

This PC software is provided solely for test and demonstration purposes. In a real application, the ‘F300 device
with the TC-RTC firmware is meant to be connected to other microcontrollers that have an SMBus interface. Refer
to "AN293: Temperature Compensated Real Time Clock Reference Design Programmer's Guide" for more details
on the SMBus interface implementation.
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7. Schematic
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8. Bill of Materials

Item Qty Reference Value Type Manufacturer P/N Footprint
1 13 C1,C2,C4,C6,C10

C12,C13,C14,C15
C16,C17,C18,C19

0u1F X7R AVX 0805YC104MAT2A 0805

2 2 C11,C20 1u0F X7R AVX 0805YC105MAT2A 0805

3 1 C3 1000uF/16V Electrolit SANYO 16MV1000FA CAPMV-FA_10_125

4 1 C7 33uT/25V Tantalum Vishay 293D336X9025D2T Case-D

5 1 C5 2u2F X7R  0805YC225MAT2A 0805

6 2 C8,C9 18pF NPO AVX 0805YA180MAT2A 0805

7 1 D1 B140  Diodes Inc. B140 SMA

8 1 D2 Red  Kingbright L-7104EC LED_3mm

9 1 D3 Green 2mA  Kingbright L-934LGD LED_3mm

10 1 J1 HEADER 6X2  Weitronics 144-11-012-10-10 HED6x2

11 1 J2 HEADER 2  Weitronics 143-11-002-10-10 HED2

12 1 J3 HEADER4X2  Weitronics 144-11-008-10-10 HED4x2

13 1 J4 Box 10pin  Molex 87256-1011 BOX5x2

14 1 J5 DB9 Female RA D-Type Kycon K22-E9S-NJ d_type_9P

15 1 J6 DB25Female RA D-Type Kycon K22-E25S-NJ d_type_25P

16 1 P1 PHONEJACK  Kycon RTC Commp CONPWR

17 2 R2,R23 2R  AVX CR-21-200J-T 0805

18 2 R4,R5 100R  AVX CR-21-101J-T 0805

19 1 R3 470R  AVX CR-21-471J-T 0805

20 3 R10,R14,R15 1K  AVX CR-21-102J-T 0805

21 1 R16 100K  AVX CR-21-105J-T 0805

22 6 R8,R9,R11,R12,R
21,R22

10K  AVX CR-21-104J-T 0805

23 1 R13 10M  AVX CR-21-107J-T 0805

24 1 R17 750R  AVX CR-21-751J-T 0805

25 1 R18 4K75  AVX CR-21-4751J-T 0805

26 2 R19,R20 33R  YAGEO RC2512-330 2512

27 2 SW1,SW2 PUSHBUTTON  Bourns SDTX-610 PB-TC0112

28 6 TP31,TP33,TP36,
TP37,TP41,TP53

Test point SMT Keystone 5015 SMT-TP

29 1 U1 L4931CD33  STG L4931CD33 SO-8

30 1 U3 C8051F300  Silicon Labs C8051F300 QFN-11

31 1 U4 74LCX07  National LM339 SO-14

32 1 U5 MAX3224  Maxim MAX3224E SSOP-20

33 1 Y1 32.768 kHz  Gollege SM26F-A GWX-38
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APPENDIX A—TC-RTC: SUPPORTED COMMANDS

TC-RTC Firmware with UART Interface
The TC-RTC firmware with UART interface supports a set of commands to read/write date and time. The
supported commands along with explanations are listed below:

s – Toggles auto-display mode that displays time once every second.
r xx yy – Read yy bytes starting at address xx.
w xx yy data – Write yy bytes starting at address xx.

Notes:
1. The commands are case-sensitive. Only lower-case letters are accepted.
2. The addresses should be in decimal format (e.g., address 0x1F is entered as 31).
3. See “Appendix B—TC-RTC: Implementation Details”  for information on how the RTC register data is formatted.

Write Command Examples
Date/Time: 11:05:39 AM, Saturday, December, 08, 1979→39 05 51 06 08 12 79
w000739055106081279
Time: 21: 48: 22→22 48 21
w0003224821
Day: Tuesday→02
w030102
NVRAM data write: 01 02 03 starting at address 0x1F (31)→31 01 02 03
w3103010203

Read Command Examples
Date/Time: r0007
NVRAM (all 56 bytes): r0856
NVRAM (4 bytes starting at address 26): r2604

TC-RTC Firmware with SMBus Interface
The TC-RTC firmware with the SMBus interface implements a SMBus Slave device with a Slave Address of 0xD0.
The device operates in one of two modes: Slave Receiver Mode or Slave Transmitter Mode. In Slave Receiver
Mode, it receives address and data from the Master and writes it to the RTC or NVRAM registers. In Slave
Transmitter Mode, it sends data from the RTC or NVRAM registers to the Master. Refer to "AN293: Temperature
Compensated Real Time Clock Reference Design Programmer's Guide" for more details on the SMBus interface
implementation.
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APPENDIX B—TC-RTC: IMPLEMENTATION DETAILS

UART Communication Parameters
Baud rate: 9600 bps
Data format: 8 data bits, 1 stop bit, no parity
Flow control: None

RTC and NVRAM Registers—Data Format

Figure 10. RTC and NVRAM Registers—Data Format
Notes:

1. The contents of the time and calendar registers are in binary coded decimal (BCD) format. 
2. The Clock Halt (CH) bit, when set to zero, will disable the RTC.
3. The 12/24 bit selects 12-hour mode if set to one.
4. In 12-hour mode, the AM/PM bit selects “PM” if set to one. In 24-hour mode, this bit is the second 10-hour bit (20-23 

hours).

Seconds

Minutes

Hours

Day of Week

Date

Month

Year

Control (Reserved)

NVRAM
56 x 8

00H

01H

02H

03H

04H

05H

06H

07H

08H

3FH

Address
Bit7 Bit6 Bit5 Bit4 Bit3 Bit2 Bit1 Bit0

CH

0

0

0 0 0 0 0

0

0 0 0

0

A/P
12 /
24

Range

00-59

00-59

01-31

1-7

01-12

00-99

01-12
01-23

(Stored in non-volatile Flash Memory)
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NOTES:
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Contact Information
Silicon Laboratories Inc.
4635 Boston Lane
Austin, TX 78735
Email: MCUinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 
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